Internet Access

Wired

Wireless

VPN

Prerequisites for joining the network

  • As part of the registration process you MUST agree to the Acceptable Network Usage policy laid down by Oxford University IT Services.
  • Your device must have an operating system that is currently supported by the manufacturer. This refers to if the device is still receiving security updates. Unsupported operating systems are Windows Vista and below and Mac OS 10.9 and below (Mac OS 10.9 is soon to lose support as well). If you’re running Linux, you should know if it's kept updated or not.
  • There must be an up to date Anti-virus solution on your device as well as a functioning Firewall. Most operating systems come with a firewall built in, which are more than sufficient.